Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

...

Section
Column
width33%

You can manually download the root certificate and any intermediate certificates needed when using SSL-based websites or services at NPS.   

The CA-2 root is always required, and you'll also need to install the intermediate certificate for each application you intend to use.  E.g. For the NPS streaming video, your browser needs to trust CA-2 and both CA-21, CA-27, and CA-28.     By installing all the certificates, your web browser will trust all DOD sites that use SSL - not just those currently in use here at NPS.

Firefox users - Firefox uses its own set of trusted certificates, outside of the operating system. This is the same on windows and Mac. Please keep that in mind when you are installing them manually. click here for help with installing the certificates in Firefox.

Column
width66%

Certificate

Purpose

DOD CA-2

Root certificate for all intermediates - required for all uses.

Certificate

Purpose

DOD CA-21

NPS Streaming Video

DOD CA-22

Not currently used by NPS

DOD CA-23

Not currently used by NPS

DOD CA-24

Not currently used by NPS

DOD CA-25

Not currently used by NPS

DOD CA-26

Not currently used by NPS

DOD CA-27

NPS Extranet, Faculty Website, NPS Survey, NPS Webmail, NPS AD/LDAP, NPS Streaming Video

DOD CA-28

NPS

DOD CA-29

Not currently used by NPS

DOD CA-30

Not currently used by NPS

DOD CA-31Not currently used by NPS
DOD CA-32Not currently used by NPS

 

 

Download All

All certificates listed above in one archive